Paladins PC Connection issues.
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 15, 2018 - 11:59 EDT
Investigating
We are investigating the connection issues affecting #Paladins #PC
Posted about 1 month ago. Jul 15, 2018 - 11:30 EDT
This incident affected: Paladins (Paladins PC).