Tribes PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Tribes Ascend is back up and accepting logins.
Posted 7 months ago. Nov 30, 2016 - 17:33 EST
Identified
#Tribes Ascend is down for emergency maintenance and will return to service shortly
Posted 7 months ago. Nov 30, 2016 - 15:39 EST
Investigating
Automated services have detected a possible problem with #Tribes PC. We are investigating.
Posted 7 months ago. Nov 30, 2016 - 15:04 EST