Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident has been resolved.#smite #paladins #tribes
Posted 10 months ago. Jul 17, 2016 - 03:49 EDT
Update
Investigating: We are currently investigating this issue.#paladins #smie #tribes
Posted 10 months ago. Jul 17, 2016 - 03:46 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted 10 months ago. Jul 17, 2016 - 03:38 EDT