Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have been resumed, and Matches should be launching normally.
Apologies for the inconvenience.
Posted 11 months ago. Sep 08, 2016 - 15:59 EDT
Update
We have stopped login's temporarily on SMITE XBOX#smite xbox
Posted 11 months ago. Sep 08, 2016 - 15:52 EDT
Identified
We are currently working to resolve the match making issues in #Smite on #Xbox.
Posted 11 months ago. Sep 08, 2016 - 15:47 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 11 months ago. Sep 08, 2016 - 15:36 EDT