Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. #paladinspc
Posted about 2 months ago. Jan 27, 2017 - 08:22 EDT
Update
There is a software problem with this patch, and we are working to fix ASAP # paladins pc
Posted about 2 months ago. Jan 27, 2017 - 06:27 EDT
Update
Investigating: We are currently investigating this Paladins PC issue. #paladinspc
Posted about 2 months ago. Jan 27, 2017 - 05:57 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 2 months ago. Jan 27, 2017 - 05:42 EDT
This incident affected: Paladins PC.