Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 06, 2017 - 13:01 EDT
Monitoring
We are resuming logins to Paladins and are monitoring the game.
Posted 4 months ago. Apr 06, 2017 - 12:17 EDT
Investigating
We are still working on issues with Paladins PC
Posted 4 months ago. Apr 06, 2017 - 11:45 EDT
Monitoring
Logins have been resumed. We are currently monitoring.
Posted 4 months ago. Apr 06, 2017 - 11:36 EDT
Update
We are performing a restart of the Paladins PC environment.
Posted 4 months ago. Apr 06, 2017 - 11:27 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 4 months ago. Apr 06, 2017 - 11:17 EDT
This incident affected: Paladins PC.