Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart has been completed.
Posted 28 days ago. Mar 24, 2018 - 05:25 EDT
Identified
We are performing an emergency restart on #Smite #PS4
Posted 28 days ago. Mar 24, 2018 - 05:09 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 28 days ago. Mar 24, 2018 - 05:04 EDT
This incident affected: Smite PS4 - North America / Europe.