Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 25, 2017 - 19:38 EDT
Identified
Steam services may be impacting users ability to login to #Paladins on #PC.
Posted Apr 25, 2017 - 19:11 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Apr 25, 2017 - 19:07 EDT
This incident affected: Paladins (Paladins PC).