Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Paladins PC issue has been resolved
Posted 5 months ago. Jul 26, 2017 - 14:32 EDT
Monitoring
#Paladins issue has been resolved and we will continue to monitor closely
Posted 5 months ago. Jul 26, 2017 - 14:10 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 5 months ago. Jul 26, 2017 - 12:47 EDT