Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue impacting #SMITE PS4 has been resolved
Posted 5 months ago. Jan 09, 2017 - 12:19 EST
Monitoring
We have resolved the issue impacting #SMITE PS4; we are continuing to monitor.
Posted 5 months ago. Jan 09, 2017 - 12:13 EST
Identified
We have identified an issue impacting #SMITE PS4; some users will encounter difficulty logging in to the game; we are actively working the issue and will provide updates shortly.
Posted 5 months ago. Jan 09, 2017 - 12:08 EST
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 5 months ago. Jan 09, 2017 - 11:58 EST
This incident affected: Smite PS4 - North America / Europe.