Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The #SMITE XBOX issue has been resolved.
Posted 9 months ago. Oct 28, 2016 - 00:39 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 9 months ago. Oct 28, 2016 - 00:18 EDT