Pausing Smite PC logins for a few moments to restart a service of the game
Incident Report for Hi-Rez Studios, Inc
Resolved
We have resumed logins. #SMITEPC
Posted 7 months ago. Apr 12, 2017 - 14:51 EDT
Identified
We will be pausing Smite PC logins for a few moments to restart a service of the game... Sorry for the inconvenience. #SmitePC
Posted 7 months ago. Apr 12, 2017 - 14:44 EDT
This incident affected: Smite PC - North America / Europe.