Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Incident with #SMITE #XBOX has been resolved.
Posted 9 months ago. Jul 19, 2016 - 20:31 EDT
Monitoring
#SMITE #XBox has been addressed and we are continuing to monitor the situation
Posted 9 months ago. Jul 19, 2016 - 20:16 EDT
Identified
We have identified issues with #SMITE #XBOX and are working actively to resolve.
Posted 9 months ago. Jul 19, 2016 - 19:56 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 9 months ago. Jul 19, 2016 - 19:41 EDT