Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue has been identified on #Smite #Xbox and was resolved.
Posted 12 days ago. Oct 07, 2017 - 00:28 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 12 days ago. Oct 06, 2017 - 23:14 EDT
This incident affected: Smite Xbox - North America / Europe.