Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 20, 2018 - 12:49 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 month ago. Apr 20, 2018 - 12:09 EDT
This incident affected: Smite Xbox - North America / Europe.