Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. PaladinsPC
Posted 3 months ago. Feb 04, 2017 - 10:34 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 3 months ago. Feb 04, 2017 - 09:11 EST
This incident affected: Paladins PC.