Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Connectivity appears to be stabilized at this point in time.
Sorry for the inconvenience.
#SMITE
Posted about 1 year ago. Apr 08, 2016 - 19:09 EDT
Update
We are investigating connectivity issues with our Game services.
Sorry for the inconvenience.
#SMITE
Posted about 1 year ago. Apr 08, 2016 - 18:40 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Apr 08, 2016 - 18:33 EDT