HiRez Games - Issue with in-game sales and My Account website
Incident Report for Hi-Rez Studios, Inc
Resolved
Issue with in-game sales and My Account website #SMITE #PALADINS #TRIBES
Posted 5 months ago. Jan 20, 2017 - 18:45 EST
Monitoring
We have addressed an issue with in-game sales and My Account website; we are continuing to monitor #SMITE #PALADINS #TRIBES
Posted 5 months ago. Jan 20, 2017 - 18:38 EST
Identified
We are experiencing an issue with in-game sales and My Account website; we are working to resolve #SMITE #PALADINS #TRIBES
Posted 5 months ago. Jan 20, 2017 - 18:29 EST
This incident affected: Smite PC - North America / Europe, Smite Xbox - North America / Europe, Smite PS4 - North America / Europe, Paladins PC, Paladins Xbox, Paladins PS4, and Tribes Ascend.