Smite PC Suspending Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC logins have been returned to normal; apologies for the inconvenience.
Posted about 1 year ago. Mar 15, 2016 - 16:14 EDT
Investigating
We will be halting logins on Smite PC for a short amount of time, at 4:15 PM EST.
Sorry for the inconvenience.
#SMITE
Posted about 1 year ago. Mar 15, 2016 - 15:58 EDT