Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Mar 05, 2016 - 19:03 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Mar 05, 2016 - 15:54 EST