Smite PC Connection Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 29, 2017 - 01:05 EDT
Monitoring
We are currently monitoring Smite PC. #SMITE PC
Posted about 2 months ago. Jan 28, 2017 - 22:16 EDT
Identified
We are currently working on issues with Smite PC. #SMITE PC
Posted about 2 months ago. Jan 28, 2017 - 22:01 EDT
This incident affected: Smite PC - North America / Europe.