Paladins PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Sep 29, 2017 - 14:44 EDT
Monitoring
Logins have been re-enabled for #Paladins #PS4 , we are continuing to monitor the situation.
Posted about 2 months ago. Sep 29, 2017 - 14:23 EDT
Identified
We have momentarily limited logins for #Paladins #PS4
Posted about 2 months ago. Sep 29, 2017 - 14:21 EDT
Investigating
Automated services have detected a possible problem with #Paladins PS4. We are investigating.
Posted about 2 months ago. Sep 29, 2017 - 14:11 EDT
This incident affected: Paladins PS4.