Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 11 days ago. Jan 10, 2018 - 12:27 EST
Identified
We are performing a restart of Smite PC
Posted 11 days ago. Jan 10, 2018 - 12:21 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 11 days ago. Jan 10, 2018 - 12:07 EST