Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #Smite PC
Posted about 2 months ago. Feb 05, 2017 - 09:29 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 2 months ago. Feb 05, 2017 - 08:56 EDT
This incident affected: Smite PC - North America / Europe.