Restart Smite PC
Incident Report for Hi-Rez Studios, Inc
Resolved
This restart has been completed
Posted about 2 months ago. Feb 02, 2017 - 23:36 EDT
Investigating
We will be restart #Smite on #PC
Posted about 2 months ago. Feb 02, 2017 - 22:45 EDT
This incident affected: Smite PC - North America / Europe.