Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PS4 has recovered.
Posted about 1 month ago. Feb 18, 2017 - 13:22 EDT
Monitoring
emergency restart of #SMITE PS4 is complete and logins enabled; we are continuing to monitor
Posted about 1 month ago. Feb 18, 2017 - 12:57 EDT
Identified
we have to perform and emergency restart of #SMITE PS4; game back shortly
Posted about 1 month ago. Feb 18, 2017 - 12:36 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted about 1 month ago. Feb 18, 2017 - 12:27 EDT
This incident affected: Smite PS4 - North America / Europe.