Smite XBox Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 19 days ago. Jan 03, 2018 - 08:57 EST
Identified
We will be restarting #Smite #XBox momentarily to address an issue with parties
Posted 19 days ago. Jan 03, 2018 - 08:00 EST
This incident affected: Smite Xbox - North America / Europe.