Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite Xbox incident has been resolved#smite
Posted over 1 year ago. Apr 23, 2016 - 00:39 EDT
Identified
Identified: The Smite XBOX issue has been identified and a fix is being implemented#smite
Posted over 1 year ago. Apr 23, 2016 - 00:33 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted over 1 year ago. Apr 23, 2016 - 00:31 EDT