Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This issues is now resolved. We will continue to monitor and we apologize for any inconvenience.
Posted 10 months ago. Feb 16, 2017 - 13:46 EST
Monitoring
We are currently monitoring issues with Paladins PC. #PALADINS PC
Posted 10 months ago. Feb 16, 2017 - 10:47 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 10 months ago. Feb 16, 2017 - 10:39 EST
This incident affected: Paladins PC.