Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issues with #SMITE #PS4 have been resolved.
Posted 7 months ago. May 05, 2017 - 23:49 EDT
Monitoring
A fix for #SMITE #PS4 has been implemented, and we are monitoring the results.
Posted 7 months ago. May 05, 2017 - 23:15 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 7 months ago. May 05, 2017 - 23:07 EDT
This incident affected: Smite PS4 - North America / Europe.