Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Dec 08, 2016 - 23:51 EDT
Update
We are still working on restoring logins for SMITE PC. #SMITE
Posted 4 months ago. Dec 08, 2016 - 23:28 EDT
Update
We are currently working to restore logins to #Smite PC
We apologize for the inconvenience.
Posted 4 months ago. Dec 08, 2016 - 23:00 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 4 months ago. Dec 08, 2016 - 22:49 EDT