Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC and XBox had a momentary datacenter connectivity issue. The condition has been resolved and the games should be operating normally.
Posted almost 2 years ago. Feb 22, 2016 - 18:43 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted almost 2 years ago. Feb 22, 2016 - 18:34 EST