Smite PC - Oceania Servers
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 02, 2016 - 15:06 EST
Update
#SMITE PC logins disabled temporarily to stabilize load; we will be re-opening the game shortly.
Posted almost 2 years ago. Feb 02, 2016 - 13:48 EST
Identified
#SMITE PC servers in Oceania are taking much longer than normal to get the Season 3 update; OPS will get them on line as soon as the transfers are complete; will post again when they are back on line.
Posted almost 2 years ago. Feb 02, 2016 - 13:13 EST