Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Brief data center issue
Posted almost 2 years ago. Feb 18, 2016 - 05:47 EST
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted almost 2 years ago. Feb 18, 2016 - 05:39 EST