Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Feb 22, 2016 - 19:42 EST
Update
#SMITE XBox: A brief connectivity issue at one of our datacenters caused a small drop in players. The issue has been resolved.
Posted over 1 year ago. Feb 22, 2016 - 19:41 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted over 1 year ago. Feb 22, 2016 - 19:33 EST