Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 02, 2017 - 22:33 EDT
Identified
We are working to restore logins and matchmaking services to #Smite on #PC
Posted about 2 months ago. Feb 02, 2017 - 22:27 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 2 months ago. Feb 02, 2017 - 22:11 EDT
This incident affected: Smite PC - North America / Europe.