Smite XBOX Loggin Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 25, 2016 - 22:14 EST
Update
Expect about 15min of downtime #smite
Posted almost 2 years ago. Jan 25, 2016 - 21:23 EST
Update
We will be doing a quick restart #smite
Posted almost 2 years ago. Jan 25, 2016 - 21:23 EST
Investigating
We are Investigating the issue #smite
Posted almost 2 years ago. Jan 25, 2016 - 21:06 EST