Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
There was a momentary issue with #SMITE PC. Some users were dropped as a result of a datacenter issue. Game appears to be recovering normally.
Posted about 1 year ago. Feb 20, 2016 - 14:47 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Feb 20, 2016 - 14:27 EST