Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 03, 2017 - 05:39 EST
Identified
We are working to restore services on #Smite #PC
We apologize for the inconvenience.
Posted 7 months ago. Jan 03, 2017 - 05:19 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 7 months ago. Jan 03, 2017 - 05:15 EST
This incident affected: Smite PC - North America / Europe.