Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Logins have now returned to normal.
#SMITE #PC
Posted 5 months ago. Mar 20, 2017 - 20:13 EDT
Identified
We are currently working to resolve the issues effecting login queues. #SMITE #PC
Posted 5 months ago. Mar 20, 2017 - 19:54 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 5 months ago. Mar 20, 2017 - 19:53 EDT
This incident affected: Smite PC - North America / Europe.