Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This SMITE XBOX incident has been resolved
Posted about 1 year ago. Mar 23, 2016 - 01:32 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Mar 22, 2016 - 23:33 EDT