Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite PC is back up. #SMITE #PC
Posted 4 months ago. Mar 12, 2017 - 00:52 EST
Monitoring
We are back up and monitoring SMITE PC. #SMITE #PC
Posted 4 months ago. Mar 12, 2017 - 00:45 EST
Identified
We are working to restore logins for Smite PC. #SMITE #PC
Posted 4 months ago. Mar 12, 2017 - 00:34 EST
Update
We are looking into issues with Smite PC. #SMITE #PC
Posted 4 months ago. Mar 12, 2017 - 00:21 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 4 months ago. Mar 11, 2017 - 23:59 EST
This incident affected: Smite PC - North America / Europe.