Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved#smite
Posted about 1 year ago. Jun 24, 2016 - 14:17 EDT
Update
Investigating: We are currently investigating this Smite PC issue#smite
Posted about 1 year ago. Jun 24, 2016 - 14:02 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Jun 24, 2016 - 13:54 EDT