Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 8 months ago. Sep 25, 2016 - 05:15 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 8 months ago. Sep 25, 2016 - 03:28 EDT