Smite Xbox login issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 18, 2016 - 23:51 EST
Identified
The issue has been identified and a fix is being implemented.
Posted almost 2 years ago. Feb 18, 2016 - 23:33 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted almost 2 years ago. Feb 18, 2016 - 23:32 EST
Identified
Xbox live is having issues, players may have trouble logging in to smite xbox
#smite
Posted almost 2 years ago. Feb 18, 2016 - 23:32 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted almost 2 years ago. Feb 18, 2016 - 23:27 EST