Smite PC emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 days ago. May 18, 2018 - 09:18 EDT
Monitoring
Restart has been completed.
Posted 2 days ago. May 18, 2018 - 07:29 EDT
Investigating
We are performing an emergency restart on #Smite #PC
Posted 2 days ago. May 18, 2018 - 07:12 EDT
This incident affected: Smite PC - North America / Europe.