Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved.#smite
Posted 9 months ago. Nov 11, 2016 - 17:09 EST
Update
We are performing an emergency restart on Smite PC #Smite.
Posted 9 months ago. Nov 11, 2016 - 16:44 EST
Identified
We are currently working to resolve the current issues effecting #Smite on #PC.
We apologize for the inconvenience.
Posted 9 months ago. Nov 11, 2016 - 16:40 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 9 months ago. Nov 11, 2016 - 16:26 EST