Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have resolved the issues with Hirez Games. #SMITE #PALADINS
Posted 4 months ago. Dec 28, 2016 - 19:23 EST
Update
We are still working on restoring Hirez Games. #SMITE #PALADINS
Posted 4 months ago. Dec 28, 2016 - 18:31 EST
Update
We are still working on issues with Hirez Games. #SMITE #PALADINS
Posted 4 months ago. Dec 28, 2016 - 18:00 EST
Identified
We are currently looking in to issues with Hirez Games. #PALADINS #SMITE
Posted 4 months ago. Dec 28, 2016 - 17:37 EST
Investigating
Automated services have detected a possible discovery issue that may impact multiple games. We are investigating. #SMITE #Paladins
Posted 4 months ago. Dec 28, 2016 - 17:33 EST
This incident affected: Smite PC - North America / Europe, Smite Xbox - North America / Europe, Smite PS4 - North America / Europe, Paladins PC, and Tribes Ascend.