Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Sep 22, 2017 - 10:42 EDT
Identified
We are limiting logins momentarily for #Paladins PC while we fix an issue
Posted Sep 22, 2017 - 10:21 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Sep 22, 2017 - 10:17 EDT