Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. #paladinspc
Posted 8 months ago. Jan 25, 2017 - 13:26 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 8 months ago. Jan 25, 2017 - 13:17 EST
This incident affected: Paladins PC.